Skip to main content
CVE-2026-40467VulnerabilityPublished Updated

Red Hat Security Advisory: gawk security update

Affects Red Hat gawkSource GCVE Database

0
Compare

Mentioned vulnerabilities

Authoritative record:CVE-2026-40467· Medium 5.1

Not known to be exploited · CVSS 5.1 Medium : upgrade the Debian debian/gawk package to 5.4.1 when convenient.

Data as of 29 Oct 2026, 09:13 UTC

CVSS 4.0 base score
5.1Medium
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.2% chance of exploitation in 30 days – higher than 11% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 5.4.1
CVSS:4.0/AV:L/AC:L/AT:N/PR:N/UI:N/VC:N/VI:N/VA:L/SC:N/SI:N/SA:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 13 Jul 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 29 Oct 2026.

What to do

Upgrade the Debian debian/gawk package to 5.4.1.

Affected software

ProductAffectedFixed in
GNUgawkAffected
  • <=5.4.0
Fixed in–
Debiandebian/gawkpkg:deb/debian/gawkOther threatsAffected
  • <5.4.1
Fixed in
  • 5.4.1

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

Description

The gawk packages contain the GNU version of awk, a text processing utility. Awk interprets a special-purpose programming language to do quick and easy text pattern matching and reformatting jobs. Security Fix(es): * gawk: gawk: Memory corruption via integer overflow (CVE-2026-40468) * gawk: Gawk: Buffer overflow in ftype() routine may lead to code execution or denial of service (CVE-2026-40553) * gawk: gawk: Denial of Service due to Use After Free vulnerability in io.c (CVE-2026-40467) For more details about the security issue(s), including the impact, a CVSS score, acknowledgments, and other related information, refer to the CVE page(s) listed in the References section.

References

Community reviews

Loading reviews…