Skip to main content
CVE-2025-69873VulnerabilityPublished Updated

Red Hat Security Advisory: General availability of the satellite/iop-remediations-rhel9 container image

Affects Red HatSource GCVE Database

0
Compare
Authoritative record:CVE-2025-69873· Low 2.9

Not known to be exploited · CVSS 2.9 Low : upgrade Red Hat to 8.17.2 or 6.14.0 when convenient.

Data as of 5 Nov 2026, 19:19 UTC

CVSS 3.1 base score
2.9Low
How severe the flaw is on the 0–10 CVSS scale.
Patch
Available – fixed in 8.17.2, 6.14.0
CVSS:3.1/AV:L/AC:H/PR:N/UI:N/S:U/C:N/I:N/A:L

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 11 Feb 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 5 Nov 2026.

What to do

Upgrade ajv to 8.17.2 or 6.14.0.

Affected software

ProductAffectedFixed in
ajv.jsajvAffected
  • >=7.0.0 <8.17.2
Fixed in
  • 8.17.2
ajv.jsajvAffected
  • <6.14.0
Fixed in
  • 6.14.0

AI-suggested

Red Hat advises disabling the $data feature in ajv if it is not required by the application. If $data must be used, implement strict validation of input fields referenced by the pattern keyword to ensure only expected and safe characters are allowed. Users should follow the vendor guidance to mitigate risk.

Description

CVE-2025-69873 is a vulnerability in the ajv library used by Red Hat Lightspeed in Satellite. When the $data option is enabled, an attacker can supply a malicious regular expression pattern that triggers a Regular Expression Denial of Service (ReDoS), causing high CPU consumption and application unresponsiveness. The vulnerability requires the $data feature to be enabled and attacker ability to send crafted input. The flaw is rated with important severity due to its potential to cause denial of service with relatively small payloads.

References

Community reviews

Loading reviews…