Skip to main content
CVE-2024-46951VulnerabilityPublished Updated

Red Hat Security Advisory: ghostscript security update

Affects Red Hat ghostscriptSource GCVE Database

0

Mentioned vulnerabilities

Authoritative record:CVE-2024-46951· High 7.8

Not known to be exploited · CVSS 7.8 High : upgrade Red Hat ghostpdl to 10.04.0 soon.

Data as of 26 Oct 2026, 09:15 UTC

CVSS 3.1 base score
7.8High
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.3% chance of exploitation in 30 days – higher than 29% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 10.04.0
CVSS:3.1/AV:L/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 10 Nov 2024

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponised: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.

What to do

Upgrade artifexsoftware/ghostpdl to 10.04.0.

Affected software

ProductAffectedFixed in
GitHubartifexsoftware/ghostpdlpkg:github/artifexsoftware/ghostpdlOther threatsAffected
  • <10.04.0
Fixed in
  • 10.04.0

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

Red Hat has released updated Ghostscript packages for Red Hat Enterprise Linux 10 and its variants to address these vulnerabilities. Users should apply the security update as described in Red Hat advisory RHSA-2025:7499 and the referenced article https://access.redhat.com/articles/11258. Applying the official update fully mitigates the vulnerabilities. No additional mitigation steps are indicated by the vendor advisory.

Description

Multiple security vulnerabilities have been identified in the Ghostscript suite used for rendering PostScript and PDF documents. These include buffer overflow, arbitrary code execution, directory traversal, path traversal, and out-of-bounds data access issues. The vulnerabilities affect Red Hat Enterprise Linux 10 and related products. Red Hat has issued a security advisory with updates to address these issues. The overall severity of these vulnerabilities is rated as moderate.

References

Community reviews

Loading reviews…