Skip to main content
CVE-2025-48384VulnerabilityPublished Updated

Red Hat Security Advisory: git security update

Affects Red Hat gitSource GCVE Database

0
Compare

Not known to be exploited : upgrade the Red Hat redhat/git package to 2.18.4-5.el8_2.1 soon.

Data as of 1 Nov 2026, 12:17 UTC

Severity
High

Rated by Threat Radar · No CVSS score from NVD or the CNA

Patch
Available – fixed in 2.18.4-5.el8_2.1

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 24 Jul 2025

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 1 Nov 2026.

What to do

Upgrade the Red Hat redhat/git package to 2.18.4-5.el8_2.1.

Affected software

ProductAffectedFixed in
Red Hatredhat/gitpkg:rpm/redhat/gitOther threatsAffected
  • >=2.18.4 <2.18.4-5.el8_2.1
Fixed in
  • 2.18.4-5.el8_2.1

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

Red Hat has released updated Git packages that fix this vulnerability. Users of Red Hat Enterprise Linux 8.2 Advanced Update Support should apply the provided security update as detailed in the Red Hat advisory RHSA-2025:11793 and the update instructions at https://access.redhat.com/articles/11258. Applying this update mitigates the risk of arbitrary code execution via Git.

Description

A security update for Git addresses an arbitrary code execution vulnerability identified as CVE-2025-48384. Git is a distributed version control system that allows users to work with complete revision history locally. This vulnerability could allow an attacker to execute arbitrary code. Red Hat has issued an important security advisory for Red Hat Enterprise Linux 8.2 Advanced Update Support, providing updated Git packages to fix this issue.

References

Community reviews

Loading reviews…