Skip to main content
CVE-2024-2961VulnerabilityPublished Updated

Red Hat Security Advisory: glibc security update

Affects Red Hat glibcSource GCVE Database

0
Compare
Authoritative record:CVE-2024-2961· High 7.3

Public exploit available (Metasploit) · CVSS 7.3 High : upgrade the affected Debian packages to 2.40 as a priority.

Data as of 5 Nov 2026, 14:04 UTC

CVSS 3.1 base score
7.3High
How severe the flaw is on the 0–10 CVSS scale.

Thin evidence

One scorer or none
CVSS scores by source
CISA-ADPCVSS 3.17.3
Patch
Available – fixed in 2.40
CVSS:3.1/AV:L/AC:L/PR:N/UI:N/S:U/C:L/I:L/A:H

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 17 Apr 2024

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: evidence found.

    1 Metasploit module

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 5 Nov 2026.

What to do

Upgrade glibc and the Debian debian/glibc package and the Red Hat redhat/glibc package to 2.40.

Affected software

ProductAffectedFixed in
The GNU C LibraryglibcAffected
  • >=2.1.93 <2.40
Fixed in
  • 2.40
Debiandebian/glibcpkg:deb/debian/glibcOther threatsAffected
  • <2.40
Fixed in
  • 2.40
Red Hatredhat/glibcpkg:rpm/redhat/glibcOther threatsAffected
  • <2.40
Fixed in
  • 2.40

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

Red Hat has released official security updates for glibc to address this vulnerability. Users and administrators should apply the provided patches as detailed in Red Hat Advisory RHSA-2024:3269 and the update instructions at https://access.redhat.com/articles/11258. Applying these updates will remediate the vulnerability. No additional mitigation steps are indicated by the vendor advisory.

Description

A security vulnerability in the GNU C Library (glibc) affects Red Hat Enterprise Linux 8 and related products. The flaw involves an out-of-bounds write in the iconv component, which may lead to remote code execution. This vulnerability is identified as CVE-2024-2961 and has been assigned a high severity rating. Red Hat has released security updates to address this issue. Exploit code is publicly available via Metasploit, but no active exploitation in the wild has been reported. The vulnerability impacts critical system libraries essential for Linux system functionality.

References

Community reviews

Loading reviews…