Skip to main content
CVE-2024-2961VulnerabilityPublished Updated

Red Hat Security Advisory: glibc security update

Affects Red Hat glibcSource GCVE Database

0
Compare
Authoritative record:CVE-2024-2961· High 7.3

Public exploit available (Metasploit) · CVSS 7.3 High : upgrade the affected Debian packages to 2.40 as a priority.

Data as of 5 Nov 2026, 14:17 UTC

CVSS 3.1 base score
7.3High
How severe the flaw is on the 0–10 CVSS scale.

Thin evidence

One scorer or none
CVSS scores by source
CISA-ADPCVSS 3.17.3
Patch
Available – fixed in 2.40
CVSS:3.1/AV:L/AC:L/PR:N/UI:N/S:U/C:L/I:L/A:H

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 17 Apr 2024

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: evidence found.

    1 Metasploit module

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 5 Nov 2026.

What to do

Upgrade glibc and the Debian debian/glibc package and the Red Hat redhat/glibc package to 2.40.

Affected software

ProductAffectedFixed in
The GNU C LibraryglibcAffected
  • >=2.1.93 <2.40
Fixed in
  • 2.40
Debiandebian/glibcpkg:deb/debian/glibcOther threatsAffected
  • <2.40
Fixed in
  • 2.40
Red Hatredhat/glibcpkg:rpm/redhat/glibcOther threatsAffected
  • <2.40
Fixed in
  • 2.40

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

Red Hat has released updated glibc packages that fix this vulnerability. Users should apply the security update as detailed in the Red Hat advisory RHSA-2024:2722. After applying the update, all services linked to the glibc library must be restarted or the system rebooted for the fix to take effect. No other mitigation steps are indicated by the vendor.

Description

A security vulnerability in the GNU C Library (glibc) affects the iconv component, where an out-of-bounds write may lead to remote code execution. This flaw impacts multiple Red Hat Enterprise Linux 8 variants and related products that use glibc. The vulnerability is identified as CVE-2024-2961 and is rated as having high severity. Red Hat has released security updates to address this issue, and applying these updates requires restarting all services linked to glibc or rebooting the system.

References

Community reviews

Loading reviews…