Skip to main content
CVE-2024-2961VulnerabilityPublished Updated

Red Hat Security Advisory: glibc security update

Affects Red Hat glibcSource GCVE Database

0
Compare

Mentioned vulnerabilities

Authoritative record:CVE-2024-2961· High 7.3

Public exploit available (Metasploit) · CVSS 7.3 High : upgrade the affected Debian packages to 2.40 as a priority.

Data as of 5 Nov 2026, 13:48 UTC

CVSS 3.1 base score
7.3High
How severe the flaw is on the 0–10 CVSS scale.

Thin evidence

One scorer or none
CVSS scores by source
CISA-ADPCVSS 3.17.3
Patch
Available – fixed in 2.40
CVSS:3.1/AV:L/AC:L/PR:N/UI:N/S:U/C:L/I:L/A:H

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 17 Apr 2024

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: evidence found.

    1 Metasploit module

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 5 Nov 2026.

What to do

Upgrade glibc and the Debian debian/glibc package and the Red Hat redhat/glibc package to 2.40.

Affected software

ProductAffectedFixed in
The GNU C LibraryglibcAffected
  • >=2.1.93 <2.40
Fixed in
  • 2.40
Debiandebian/glibcpkg:deb/debian/glibcOther threatsAffected
  • <2.40
Fixed in
  • 2.40
Red Hatredhat/glibcpkg:rpm/redhat/glibcOther threatsAffected
  • <2.40
Fixed in
  • 2.40

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

A security update for glibc is available from Red Hat as detailed in advisory RHSA-2024:3423. Users should apply the update promptly. After updating, all services linked to the glibc library must be restarted or the system rebooted for the fixes to take effect. No other specific mitigations are indicated by the vendor advisory.

Description

Multiple security vulnerabilities have been identified and fixed in the GNU C Library (glibc) packages used by Red Hat Enterprise Linux 9.0 Extended Update Support. These include an out-of-bounds write in iconv conversion (CVE-2024-2961), a stack-based buffer overflow in the netgroup cache (CVE-2024-33599), null pointer dereferences after failed netgroup cache insertion (CVE-2024-33600), netgroup cache termination on memory allocation failure (CVE-2024-33601), and incorrect assumptions about NSS callback strings (CVE-2024-33602). These flaws could lead to system instability or potential remote code execution. A security update is available and should be applied with a system reboot or service restart to take effect.

References

Community reviews

Loading reviews…