Skip to main content
CVE-2026-8631VulnerabilityPublished Updated

Red Hat Security Advisory: hplip security update

Affects Red Hat hplipSource GCVE Database

0
Compare

Mentioned vulnerabilities

Authoritative record:CVE-2026-8631· Critical 9.3

Not known to be exploited · CVSS 9.3 Critical.

Data as of 6 Nov 2026, 03:04 UTC

CVSS 4.0 base score
9.3Critical
How severe the flaw is on the 0–10 CVSS scale.
CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 20 May 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 5 Nov 2026.

What to do

Affected software

ProductAffectedFixed in
HP IncHP Linux Imaging and Printing SoftwareAffected
  • <3.26.4
Fixed in–

AI-suggested

Red Hat has released updated hplip packages (version 3.18.4-9.el8_6.1) for Red Hat Enterprise Linux 8.6 Extended Life Cycle Long Life and AUS variants that address these vulnerabilities. Users should apply these official updates as described in the Red Hat advisory (https://access.redhat.com/articles/11258) to remediate the issues. No additional mitigation actions are indicated beyond applying the vendor-provided patches.

Description

Two security vulnerabilities have been identified in the Hewlett-Packard Linux Imaging and Printing Project (HPLIP) packages used in Red Hat Enterprise Linux 8.6. These include a privilege escalation and arbitrary code execution vulnerability via operating system command injection (CVE-2026-8632) and another vulnerability involving arbitrary code execution and privilege escalation due to an integer overflow in the hpcups component (CVE-2026-8631). Red Hat has issued an important security update addressing these issues.

References

Community reviews

Loading reviews…