Skip to main content
CVE-2026-8631VulnerabilityPublished Updated

Red Hat Security Advisory: hplip security update

Affects Red Hat hplipSource GCVE Database

0
Compare

Mentioned vulnerabilities

Authoritative record:CVE-2026-8631· Critical 9.3

Not known to be exploited · CVSS 9.3 Critical.

Data as of 6 Nov 2026, 03:04 UTC

CVSS 4.0 base score
9.3Critical
How severe the flaw is on the 0–10 CVSS scale.
CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 20 May 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 5 Nov 2026.

What to do

Affected software

ProductAffectedFixed in
HP IncHP Linux Imaging and Printing SoftwareAffected
  • <3.26.4
Fixed in–

AI-suggested

Red Hat has released an updated hplip package (3.21.2-6.el9_4.1) that addresses these vulnerabilities. Users of Red Hat Enterprise Linux 9.4 should apply this update promptly to remediate the issues. For detailed update instructions, refer to the Red Hat advisory article at https://access.redhat.com/articles/11258. No additional mitigation steps are indicated by the vendor advisory.

Description

The hplip packages for Red Hat Enterprise Linux contain drivers for Hewlett-Packard printers and multi-function peripherals. Two security vulnerabilities have been identified: CVE-2026-8632, which allows privilege escalation and arbitrary code execution via operating system command injection, and CVE-2026-8631, which allows arbitrary code execution and privilege escalation via an integer overflow in hpcups. These vulnerabilities have been addressed in an updated hplip package for Red Hat Enterprise Linux 9.4. The update is rated as Important by Red Hat Product Security.

References

Community reviews

Loading reviews…