Skip to main content
CVE-2025-58098VulnerabilityPublished Updated

Red Hat Security Advisory: httpd security update

Affects Red Hat httpdSource GCVE Database

0
Compare
Authoritative record:CVE-2025-58098· High 8.3

Not known to be exploited · CVSS 8.3 High : upgrade Red Hat httpd to 2.4.66 soon.

Data as of 6 Nov 2026, 07:08 UTC

CVSS 3.1 base score
8.3High
How severe the flaw is on the 0–10 CVSS scale.
Patch
Available – fixed in 2.4.66
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:L

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 5 Dec 2025

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 5 Nov 2026.

What to do

Upgrade apache/httpd to 2.4.66.

Affected software

ProductAffectedFixed in
Apacheapache/httpdpkg:rpm/apache/httpdOther threatsAffected
  • <2.4.66
Fixed in
  • 2.4.66

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

Red Hat has released updated httpd packages (version 2.4.62-4.el9_6.5) that fix this vulnerability. Users of Red Hat Enterprise Linux 9.6 Extended Update Support should apply the security update as soon as possible following Red Hat's official guidance at https://access.redhat.com/articles/11258. No additional mitigation steps are indicated beyond applying the official patch.

Description

A security vulnerability (CVE-2025-58098) affecting the Apache HTTP Server (httpd) in Red Hat Enterprise Linux 9.6 Extended Update Support has been addressed. The issue involves Server Side Includes (SSI) where the query string is added to the #exec cmd= directive, potentially leading to unintended behavior. Red Hat has released an important security update to fix this vulnerability. The advisory references updated httpd packages version 2.4.62-4.el9_6.5 and related modules. No public exploit or in-the-wild exploitation is currently known.

References

Community reviews

Loading reviews…