Skip to main content
CVE-2025-58098VulnerabilityPublished Updated

CVE-2025-58098: Apache HTTP Server · Insertion of Sensitive Information Into Sent Data

Affects Apache HTTP ServerSource CVE Database V5

0

Not known to be exploited · CVSS 8.3 High : upgrade to 2.4.66 soon.

Data as of 25 Oct 2026, 19:02 UTC

CVSS 3.1 base score
8.3High
How severe the flaw is on the 0–10 CVSS scale.
EPSS
1.4% chance of exploitation in 30 days – higher than 72% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 2.4.66
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:L

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 5 Dec 2025

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponised: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 2026-10-25.

What to do

Upgrade apache/httpd to 2.4.66.

Affected software

ProductAffectedFixed in
Apacheapache/httpdpkg:rpm/apache/httpdOther threatsAffected
  • <2.4.66
Fixed in
  • 2.4.66

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

1. Upgrade Apache HTTP Server to version 2.4.66 or later immediately to apply the official fix. 2. Review and disable Server Side Includes (SSI) if not strictly necessary, as SSI can introduce multiple security risks. 3. If SSI is required, avoid using mod_cgid and prefer mod_cgi or other safer alternatives where possible. 4. Audit web server configurations to ensure that query strings are not passed unsafely to exec commands or other shell-invoking directives. 5. Implement strict input validation and sanitization on any user-supplied data used in server-side scripts. 6. Monitor web server logs for unusual or suspicious exec command usage patterns. 7. Employ web application firewalls (WAFs) with rules targeting suspicious SSI exec command usage. 8. Conduct regular security assessments and penetration tests focusing on SSI and CGI configurations. 9. Educate administrators about the risks of enabling SSI with mod_cgid and best practices for secure server configuration.

Description

Apache HTTP Server 2.4.65 and earlier with Server Side Includes (SSI) enabled and mod_cgid (but not mod_cgi) passes the shell-escaped query string to #exec cmd="..." directives. This issue affects Apache HTTP Server before 2.4.66. Users are recommended to upgrade to version 2.4.66, which fixes the issue.

References

Community reviews

Loading reviews…