Skip to main content
CVE-2025-58098VulnerabilityPublished Updated

Red Hat Security Advisory: httpd security update

Affects Red Hat httpdSource GCVE Database

0
Compare
Authoritative record:CVE-2025-58098· High 8.3

Not known to be exploited · CVSS 8.3 High : upgrade Red Hat httpd to 2.4.66 soon.

Data as of 6 Nov 2026, 07:08 UTC

CVSS 3.1 base score
8.3High
How severe the flaw is on the 0–10 CVSS scale.
Patch
Available – fixed in 2.4.66
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:L

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 5 Dec 2025

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 5 Nov 2026.

What to do

Upgrade apache/httpd to 2.4.66.

Affected software

ProductAffectedFixed in
Apacheapache/httpdpkg:rpm/apache/httpdOther threatsAffected
  • <2.4.66
Fixed in
  • 2.4.66

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

Red Hat has released updated httpd packages that fix this vulnerability. Users of affected Red Hat Enterprise Linux 9.4 Extended Update Support and related variants should apply the security update as detailed in Red Hat advisory RHSA-2026:0141. No additional mitigation steps are indicated beyond applying the official patch.

Description

A security update for the Apache HTTP Server (httpd) addresses a vulnerability where Server Side Includes (SSI) improperly add query strings to the #exec cmd= directive. This issue is tracked as CVE-2025-58098 and affects Red Hat Enterprise Linux 9.4 Extended Update Support and related variants. The vulnerability has been rated as important by Red Hat Product Security. A fix is available in updated httpd packages provided by Red Hat.

References

Community reviews

Loading reviews…