Skip to main content
CVE-2024-42516VulnerabilityPublished

Red Hat Security Advisory: httpd security update

Affects Red Hat httpdSource GCVE Database

0
Compare

Mentioned vulnerabilities

Authoritative record:CVE-2024-42516· High 7.5

Not known to be exploited · CVSS 7.5 High : upgrade Red Hat httpd to 2.4.64 soon.

Data as of 30 Oct 2026, 03:00 UTC

CVSS 3.1 base score
7.5High
How severe the flaw is on the 0–10 CVSS scale.
Patch
Available – fixed in 2.4.64
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:H/A:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 10 Jul 2025

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 29 Oct 2026.

What to do

Upgrade apache/httpd to 2.4.64.

Affected software

ProductAffectedFixed in
Apacheapache/httpdpkg:rpm/apache/httpdOther threatsAffected
  • =2.4.0 <2.4.64
Fixed in
  • 2.4.64

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

Red Hat has released updated httpd packages for Red Hat Enterprise Linux Server Extended Life Cycle Support 7 that address these vulnerabilities. Users should apply the security update as detailed in the Red Hat advisory RHSA-2026:92590 and the referenced article https://access.redhat.com/articles/11258. No additional mitigation steps are indicated beyond applying the official update.

Description

Multiple security vulnerabilities have been identified and addressed in the Apache HTTP Server (httpd) packages provided by Red Hat. These include heap-based buffer over-reads, off-by-one out-of-bounds reads, NULL pointer dereferences, arbitrary code execution via heap-based buffer overflow, use-after-free leading to code execution or denial of service, buffer over-reads via outbound OCSP requests, denial of service via attacker-controlled FTP servers, and buffer overflow allowing security bypass. The update fixes an incomplete prior fix for CVE-2023-38709 and several new issues in various modules such as mod_proxy_ajp, mod_ldap, mod_xml2enc, and mod_proxy_html. The advisory applies to Red Hat Enterprise Linux Server Extended Life Cycle Support 7 and related architectures.

References

Community reviews

Loading reviews…