CVE-2024-42516: Apache HTTP Server · Improper Input Validation
Affects Apache HTTP ServerSource CVE Database V5
Mentioned vulnerabilities
Not known to be exploited · CVSS 7.5 High : upgrade to 2.4.64 soon.
Data as of 25 Oct 2026, 19:02 UTC
- EPSS
- 0.8% chance of exploitation in 30 days – higher than 56% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- Patch
- Available – fixed in 2.4.64
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:H/A:NExploitation evidence
Disclosed: evidence found.
CVE published 10 Jul 2025
Detectable: no evidence on record.
No public nuclei template indexed
Weaponised: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 2026-10-25.
What to do
Upgrade apache/httpd to 2.4.64.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
Apacheapache/httpdpkg:rpm/apache/httpdOther threats | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
To mitigate CVE-2024-42516, European organizations should immediately upgrade all affected Apache HTTP Server instances to version 2.4.64 or later, which contains the complete fix for this vulnerability. Beyond upgrading, organizations should audit their web applications and proxy configurations to ensure that Content-Type headers are not susceptible to injection of CRLF characters or other malicious input. Implement strict input validation and sanitization on all HTTP headers, especially those that can be influenced by user input or external sources. Employ web application firewalls (WAFs) with rules designed to detect and block HTTP response splitting attempts. Regularly monitor server logs for suspicious header manipulations or anomalies in HTTP responses. Conduct penetration testing focused on header injection vulnerabilities to verify the effectiveness of mitigations.
Description
HTTP response splitting in the core of Apache HTTP Server allows an attacker who can manipulate the Content-Type response headers of applications hosted or proxied by the server can split the HTTP response. This vulnerability was described as CVE-2023-38709 but the patch included in Apache HTTP Server 2.4.59 did not address the issue. Users are recommended to upgrade to version 2.4.64, which fixes this issue.