Skip to main content
CVE-2024-42516VulnerabilityPublished Updated

Red Hat Security Advisory: httpd security update

Affects Red Hat httpdSource GCVE Database

0
Compare

Mentioned vulnerabilities

Authoritative record:CVE-2024-42516· High 7.5

Not known to be exploited · CVSS 7.5 High : upgrade Red Hat httpd to 2.4.64 soon.

Data as of 30 Oct 2026, 03:14 UTC

CVSS 3.1 base score
7.5High
How severe the flaw is on the 0–10 CVSS scale.
Patch
Available – fixed in 2.4.64
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:H/A:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 10 Jul 2025

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 29 Oct 2026.

What to do

Upgrade apache/httpd to 2.4.64.

Affected software

ProductAffectedFixed in
Apacheapache/httpdpkg:rpm/apache/httpdOther threatsAffected
  • =2.4.0 <2.4.64
Fixed in
  • 2.4.64

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

Red Hat has released updated httpd packages for Red Hat Enterprise Linux 9.6 Extended Update Support and related variants that address all listed vulnerabilities. Users should apply these official updates promptly to remediate the security issues. Detailed update instructions are available at https://access.redhat.com/articles/11258. No indication of partial or temporary mitigations is provided; applying the vendor-supplied fixes is the recommended course of action.

Description

This Red Hat Security Advisory addresses multiple vulnerabilities in the Apache HTTP Server (httpd) packages, including heap-based buffer over-reads, buffer overflows, NULL pointer dereferences, use-after-free conditions, and denial of service issues across various modules such as mod_proxy_ajp, mod_ldap, mod_authn_socache, mod_proxy_html, and others. The advisory includes an incomplete fix for CVE-2023-38709 (tracked as CVE-2024-42516) and several new vulnerabilities with potential impacts ranging from memory disclosure and process crashes to arbitrary code execution and denial of service. The update is rated as important by Red Hat and applies to Red Hat Enterprise Linux 9.6 Extended Update Support and related variants.

References

Community reviews

Loading reviews…