Skip to main content
CVE-2024-42516VulnerabilityPublished Updated

Red Hat Security Advisory: httpd security update

Affects Red Hat httpdSource GCVE Database

0
Compare

Mentioned vulnerabilities

Authoritative record:CVE-2024-42516· High 7.5

Not known to be exploited · CVSS 7.5 High : upgrade Red Hat httpd to 2.4.64 soon.

Data as of 30 Oct 2026, 03:14 UTC

CVSS 3.1 base score
7.5High
How severe the flaw is on the 0–10 CVSS scale.
Patch
Available – fixed in 2.4.64
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:H/A:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 10 Jul 2025

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 29 Oct 2026.

What to do

Upgrade apache/httpd to 2.4.64.

Affected software

ProductAffectedFixed in
Apacheapache/httpdpkg:rpm/apache/httpdOther threatsAffected
  • =2.4.0 <2.4.64
Fixed in
  • 2.4.64

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

Red Hat has released updated httpd packages addressing these vulnerabilities for Red Hat Enterprise Linux 10.0 Extended Update Support. Users should apply the provided security update promptly following the instructions in the Red Hat advisory (https://access.redhat.com/articles/11258). No indication of partial or temporary fixes remains; the update fully addresses the listed vulnerabilities. No additional mitigations beyond applying the update are specified.

Description

Red Hat has issued an important security advisory for the Apache HTTP Server (httpd) packages addressing multiple vulnerabilities. These include heap-based buffer over-reads, buffer overflows, NULL pointer dereferences, and denial of service issues affecting various modules such as mod_proxy_ajp, mod_authn_socache, mod_xml2enc, and mod_proxy_html. The advisory covers an incomplete fix for CVE-2023-38709 (CVE-2024-42516) and several new vulnerabilities with potential impacts including arbitrary code execution, memory disclosure, process crashes, and security bypass. The update is available for Red Hat Enterprise Linux 10.0 Extended Update Support and related architectures. Users are advised to apply the update as detailed in the Red Hat advisory.

References

Community reviews

Loading reviews…