Skip to main content
CVE-2025-58098VulnerabilityPublished Updated

Red Hat Security Advisory: httpd security update

Affects Red Hat httpdSource GCVE Database

0
Compare
Authoritative record:CVE-2025-58098· High 8.3

Not known to be exploited · CVSS 8.3 High : upgrade Red Hat httpd to 2.4.66 soon.

Data as of 6 Nov 2026, 07:08 UTC

CVSS 3.1 base score
8.3High
How severe the flaw is on the 0–10 CVSS scale.
Patch
Available – fixed in 2.4.66
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:L

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 5 Dec 2025

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 5 Nov 2026.

What to do

Upgrade apache/httpd to 2.4.66.

Affected software

ProductAffectedFixed in
Apacheapache/httpdpkg:rpm/apache/httpdOther threatsAffected
  • <2.4.66
Fixed in
  • 2.4.66

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

Red Hat has released an official security update for the httpd packages that addresses CVE-2025-58098. Users running affected versions of Red Hat Enterprise Linux 10.0 Extended Update Support should apply the update as described in the Red Hat advisory (https://access.redhat.com/articles/11258). Since a fix is available, applying this update is the recommended mitigation.

Description

A security update for the Apache HTTP Server (httpd) addresses a vulnerability identified as CVE-2025-58098. The issue involves Server Side Includes (SSI) where the query string is added to the #exec cmd= directive. This vulnerability has been rated as having an Important security impact by Red Hat. The update is available for Red Hat Enterprise Linux 10.0 Extended Update Support and related variants. Users are advised to apply the update as detailed in the Red Hat advisory.

References

Community reviews

Loading reviews…