Skip to main content
CVE-2024-47252VulnerabilityPublished Updated

Red Hat Security Advisory: httpd:2.4 security update

Affects Red Hat httpd:2.4Source GCVE Database

0
Compare

Mentioned vulnerabilities

Authoritative record:CVE-2024-47252· High 7.5

Not known to be exploited · CVSS 7.5 High.

Data as of 5 Nov 2026, 15:03 UTC

CVSS 3.1 base score
7.5High
How severe the flaw is on the 0–10 CVSS scale.

Thin evidence

One scorer or none
CVSS scores by source
CISA-ADPCVSS 3.17.5
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 10 Jul 2025

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 5 Nov 2026.

What to do

Affected software

ProductAffectedFixed in
Apacheapache/httpdpkg:rpm/apache/httpdOther threatsAffected
  • <=2.4.63
Fixed in–

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

Red Hat has released updated httpd:2.4 packages for Red Hat Enterprise Linux 8 that address these vulnerabilities. Users should apply the official security update as detailed in Red Hat advisory RHSA-2025:15123 and the referenced article https://access.redhat.com/articles/11258. No additional mitigation steps are indicated beyond applying the vendor-provided update.

Description

Red Hat issued a security advisory for the Apache HTTP Server (httpd) 2.4 module addressing multiple vulnerabilities including insufficient escaping of user data in mod_ssl, access control bypass via TLS 1.3 session resumption, assertion failure in mod_proxy_http2 from untrusted input, and HTTP session hijacking via TLS upgrade. These vulnerabilities have been rated with moderate security impact. The advisory provides updated packages for Red Hat Enterprise Linux 8 to remediate these issues.

References

Community reviews

Loading reviews…