Skip to main content
CVE-2025-49630VulnerabilityPublished Updated

Red Hat Security Advisory: mod_http2 security update

Affects Red HatSource GCVE Database

0
Authoritative record:CVE-2025-49630· High 7.5

Not known to be exploited · CVSS 7.5 High : upgrade the Red Hat redhat/mod_http2 package to 9.4.2 soon.

Data as of 26 Oct 2026, 08:30 UTC

CVSS base score
7.5High
How severe the flaw is on the 0–10 CVSS scale.
EPSS
1.3% chance of exploitation in 30 days – higher than 71% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 9.4.2

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 10 Jul 2025

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponised: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.

What to do

Upgrade the Red Hat redhat/mod_http2 package to 9.4.2.

Affected software

ProductAffectedFixed in
Red Hatredhat/mod_http2pkg:rpm/redhat/mod_http2Other threatsAffected
  • >=9.4 <9.4.2
Fixed in
  • 9.4.2

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

Red Hat has released an official security update for the mod_http2 package that addresses this vulnerability. Users of Red Hat Enterprise Linux 9.4 should apply the update to versions 9.4.2 or later as provided by Red Hat. Refer to the Red Hat advisory RHSA-2025:15727 and the update instructions at https://access.redhat.com/articles/11258 for detailed remediation steps.

Description

A moderate severity vulnerability (CVE-2025-49630) exists in the Apache mod_proxy_http2 module used by Red Hat Enterprise Linux 9.4. The vulnerability is caused by untrusted client input leading to an assertion failure in the HTTP/2 protocol implementation. Red Hat has released an update to address this issue in the mod_http2 package for multiple architectures and variants of RHEL 9.4.

References

Community reviews

Loading reviews…