Skip to main content
CVE-2024-47252VulnerabilityPublished Updated

Red Hat Security Advisory: httpd:2.4 security update

Affects Red Hat httpd:2.4Source GCVE Database

0
Compare

Mentioned vulnerabilities

Authoritative record:CVE-2024-47252· High 7.5

Not known to be exploited · CVSS 7.5 High.

Data as of 5 Nov 2026, 15:03 UTC

CVSS 3.1 base score
7.5High
How severe the flaw is on the 0–10 CVSS scale.

Thin evidence

One scorer or none
CVSS scores by source
CISA-ADPCVSS 3.17.5
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 10 Jul 2025

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 5 Nov 2026.

What to do

Affected software

ProductAffectedFixed in
Apacheapache/httpdpkg:rpm/apache/httpdOther threatsAffected
  • <=2.4.63
Fixed in–

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

Red Hat has released updated packages for the httpd 2.4 module in Red Hat Enterprise Linux 8.6 to address these vulnerabilities. Users should apply the official security update RHSA-2025:15698 promptly to remediate these issues. Detailed instructions for applying the update are available at https://access.redhat.com/articles/11258. No additional mitigation steps are indicated by the vendor advisory.

Description

Red Hat has issued a security update for the Apache HTTP Server (httpd) 2.4 module addressing multiple vulnerabilities. These include insufficient escaping of user-supplied data in mod_ssl (CVE-2024-47252), an access control bypass via TLS 1.3 session resumption in mod_ssl (CVE-2025-23048), an assertion failure caused by untrusted input in mod_proxy_http2 (CVE-2025-49630), and an HTTP session hijack vulnerability via TLS upgrade (CVE-2025-49812). The update is rated as having a moderate security impact. Red Hat Enterprise Linux 8.6 systems are affected and updates are available to remediate these issues.

References

Community reviews

Loading reviews…