Skip to main content
CVE-2025-66566VulnerabilityPublished Updated

Red Hat Security Advisory: jmc security update

Affects Red Hat jmcSource GCVE Database

0
Compare
Authoritative record:CVE-2025-66566· High 8.2

Not known to be exploited · CVSS 8.2 High : upgrade Red Hat lz4-java to 1.10.1 soon.

Data as of 5 Nov 2026, 20:36 UTC

CVSS 4.0 base score
8.2High
How severe the flaw is on the 0–10 CVSS scale.
Patch
Available – fixed in 1.10.1
CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:N/VC:H/VI:N/VA:N/SC:N/SI:N/SA:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 5 Dec 2025

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 5 Nov 2026.

What to do

Upgrade com.github.yawkat/lz4-java to 1.10.1.

Affected software

ProductAffectedFixed in
Mavencom.github.yawkat/lz4-javapkg:maven/com.github.yawkat/lz4-javaOther threatsAffected
  • <1.10.1
Fixed in
  • 1.10.1

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

Red Hat has released updated packages for jmc that address this vulnerability. Users of Red Hat CodeReady Linux Builder for x86_64 9 and Extended Update Support 9.8 should apply the provided security updates as detailed in the Red Hat advisory RHSA-2026:0752 and the update instructions at https://access.redhat.com/articles/11258. No additional mitigation actions are indicated beyond applying the official update.

Description

A security update for JDK Mission Control (jmc) addresses an information disclosure vulnerability in the lz4-java library due to insufficient output buffer clearing (CVE-2025-66566). This vulnerability could potentially expose sensitive data. The update is rated as important by Red Hat and applies to Red Hat CodeReady Linux Builder for x86_64 9 and its Extended Update Support 9.8 versions.

References

Community reviews

Loading reviews…