CVE-2025-66566: yawkat lz4-java · Insertion of Sensitive Information Into Sent Data
Affects yawkat lz4-javaSource CVE Database V5
Not known to be exploited · CVSS 8.2 High : upgrade to 1.10.1 soon.
Data as of 26 Oct 2026, 14:05 UTC
- EPSS
- 0.6% chance of exploitation in 30 days – higher than 48% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- Patch
- Available – fixed in 1.10.1
CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:N/VC:H/VI:N/VA:N/SC:N/SI:N/SA:NExploitation evidence
Disclosed: evidence found.
CVE published 5 Dec 2025
Detectable: no evidence on record.
No public nuclei template indexed
Weaponised: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.
What to do
Upgrade com.github.yawkat/lz4-java to 1.10.1.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
Mavencom.github.yawkat/lz4-javapkg:maven/com.github.yawkat/lz4-javaOther threats | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
European organizations should immediately assess their software inventory to identify usage of yawkat lz4-java versions prior to 1.10.1. The primary mitigation is to upgrade all instances of lz4-java to version 1.10.1 or later, where the vulnerability is fixed. For applications where upgrading is not immediately feasible, implement compensating controls such as ensuring output buffers are explicitly cleared before reuse in custom decompression logic. Conduct code reviews to verify that decompression buffers do not retain sensitive data. Network-level protections such as input validation and filtering of compressed data from untrusted sources can reduce exposure. Employ runtime application self-protection (RASP) or intrusion detection systems to monitor for anomalous decompression requests. Additionally, review logging and monitoring to detect unusual decompression activity. Finally, update incident response plans to include scenarios involving data leakage via compression libraries.
Description
CVE-2025-66566 is a high-severity vulnerability in yawkat lz4-java versions prior to 1.10.1, where insufficient clearing of the output buffer in Java-based decompressor implementations allows remote attackers to read residual data from previous decompression operations. This can lead to disclosure of sensitive information if the output buffer is reused without proper clearing. The vulnerability does not affect JNI-based implementations and requires no authentication or user interaction to exploit. Although no known exploits are currently reported in the wild, the vulnerability poses a significant confidentiality risk. The issue is fixed in version 1.10.1 of lz4-java. European organizations using vulnerable versions in their Java applications, especially those handling sensitive data, should prioritize upgrading to mitigate potential data leakage.