Skip to main content
CVE-2024-23337VulnerabilityPublished Updated

Red Hat Security Advisory: jq security update

Affects Red Hat jqSource GCVE Database

0

Mentioned vulnerabilities

Not known to be exploited : upgrade Red Hat jq to 8.10.11 when convenient.

Data as of 26 Oct 2026, 08:30 UTC

Severity
Medium

Rated by Threat Radar · No CVSS score from NVD or the CNA

EPSS
0.4% chance of exploitation in 30 days – higher than 39% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 8.10.11

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 8 Jul 2025

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponised: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.

What to do

Upgrade Red Hat jq to 8.10.11.

Affected software

ProductAffectedFixed in
Red Hat Product Security Red HatAffected
  • >=8.0.0 <8.10.11
Fixed in
  • 8.10.11

AI-suggested

Red Hat has released updated jq packages for Red Hat Enterprise Linux 8 and related CodeReady Linux Builder variants. Users should apply these official updates as detailed in Red Hat advisory RHSA-2025:10618 and the linked article https://access.redhat.com/articles/11258 to remediate the vulnerabilities. No additional mitigation steps are indicated by the vendor.

Description

Red Hat has issued a security advisory for jq, a command-line JSON processor, addressing two vulnerabilities: a signed integer overflow (CVE-2024-23337) and a stack-buffer-overflow detected by AddressSanitizer (CVE-2025-48060). These vulnerabilities affect Red Hat Enterprise Linux 8 and related CodeReady Linux Builder packages. The update is rated as having a moderate security impact. The advisory provides updated package versions to remediate these issues.

References

Community reviews

Loading reviews…