Skip to main content
CVE-2025-37803VulnerabilityPublished Updated

SUSE · security update for kernel

Affects SUSESource GCVE Database

0

Not known to be exploited : upgrade to 9.8 or 9.6 soon.

Data as of 25 Oct 2026, 19:02 UTC

Severity
High

Rated by Threat Radar · No CVSS score from NVD or the CNA

EPSS
0.2% chance of exploitation in 30 days – higher than 16% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 9.8, 9.6

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 8 Sep 2025

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponised: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 2026-10-25.

What to do

Upgrade redhat/kernel to 9.8 or 9.6.

Affected software

ProductAffectedFixed in
Red Hatredhat/kernelpkg:rpm/redhat/kernelOther threatsAffected
  • >=9.0.0 <9.6
  • >=9.6.0 <9.8
Fixed in
  • 9.6
  • 9.8

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

A security update is available from Red Hat and SUSE that addresses this vulnerability. Systems running affected kernel versions should apply the update promptly. The update requires a system reboot to take effect. Refer to the Red Hat advisory RHSA-2025:15429 and SUSE vendor advisories for detailed patching instructions. No additional mitigation steps are indicated by the vendor.

Description

A buffer size overflow vulnerability in the Linux kernel's udmabuf component has been fixed by casting the size_limit_mb to a 64-bit unsigned integer during pglimit calculation. This issue affects certain versions of the Linux kernel used in Red Hat Enterprise Linux 9 and SUSE products. The vulnerability has been assigned CVE-2025-37803 and is rated with high severity. A security update is available and should be applied, requiring a system reboot for the fix to take effect.

References

Community reviews

Loading reviews…