Skip to main content
CVE-2024-7383VulnerabilityPublished Updated

SUSE · security update for libnbd

Affects SUSESource GCVE Database

0

Not known to be exploited · fixed in 9.9 : update SUSE when convenient.

Data as of 25 Oct 2026, 19:02 UTC

Severity
Medium

Rated by Threat Radar · No CVSS score from NVD or the CNA

EPSS
0.3% chance of exploitation in 30 days – higher than 32% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 9.9, 9.7, 9.5

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 18 Sep 2024

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponised: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 2026-10-25.

What to do

Upgrade redhat/libnbd to 9.9, 9.7 or 9.5.

Affected software

ProductAffectedFixed in
Red Hatredhat/libnbdpkg:rpm/redhat/libnbdOther threatsAffected
  • >=9.4 <9.5
  • >=9.6 <9.7
  • >=9.8 <9.9
Fixed in
  • 9.5
  • 9.7
  • 9.9

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

A security update for libnbd is available from Red Hat and should be applied promptly to affected systems. The update fixes the improper certificate validation vulnerability (CVE-2024-7383). Users should follow the instructions in the Red Hat advisory RHSA-2024:6757 and the referenced article https://access.redhat.com/articles/11258 to apply the patch. No additional mitigations are specified or required beyond applying the official update.

Description

A security update has been released for libnbd, a userspace client library for Network Block Device (NBD) clients. The update addresses an improper certificate validation vulnerability in the NBD server (CVE-2024-7383). This vulnerability could affect the security of communications between NBD clients and servers. The issue has been rated as having moderate severity by Red Hat Product Security. A patch is available and should be applied to affected systems running Red Hat Enterprise Linux 9.4 and related variants.

References

Community reviews

Loading reviews…