Skip to main content
CVE-2025-64720VulnerabilityPublished Updated

Red Hat Security Advisory: libpng security update

Affects Red Hat libpngSource GCVE Database

0

Mentioned vulnerabilities

Authoritative record:CVE-2025-64720· High 7.1

Not known to be exploited · CVSS 7.1 High : upgrade Red Hat libpng to 1.6.51 soon.

Data as of 26 Oct 2026, 09:15 UTC

CVSS 3.1 base score
7.1High
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.4% chance of exploitation in 30 days – higher than 38% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 1.6.51
CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:L/I:N/A:H

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 24 Nov 2025

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponised: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.

What to do

Upgrade pnggroup/libpng to 1.6.51.

Affected software

ProductAffectedFixed in
GitHubpnggroup/libpngpkg:github/pnggroup/libpngOther threatsAffected
  • <1.6.51 >=1.6.0
Fixed in
  • 1.6.51

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

Red Hat has released updated libpng packages in version 8.8.1 that address these vulnerabilities. Users of Red Hat Enterprise Linux 8.8 should apply the official security update as described in the Red Hat advisory RHSA-2026:0313. No additional mitigation steps are required beyond applying the provided patches.

Description

Multiple security vulnerabilities have been identified in the libpng library used in Red Hat Enterprise Linux 8.8. These include buffer overflow and out-of-bounds read issues. Red Hat has issued an important security advisory with updates to address these flaws. The vulnerabilities affect libpng versions in Red Hat Enterprise Linux 8.8 prior to 8.8.1. The advisory provides updated packages to remediate these issues.

References

Community reviews

Loading reviews…