Skip to main content
CVE-2025-32050VulnerabilityPublished Updated

SUSE · security update for libsoup

Affects SUSESource GCVE Database

0

Mentioned vulnerabilities

Not known to be exploited : upgrade to 9.8 or 9.6 soon.

Data as of 25 Oct 2026, 19:02 UTC

Severity
High

Rated by Threat Radar · No CVSS score from NVD or the CNA

EPSS
0.7% chance of exploitation in 30 days – higher than 55% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 9.8, 9.6

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 13 May 2025

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponised: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 2026-10-25.

What to do

Upgrade redhat/libsoup to 9.8 or 9.6.

Affected software

ProductAffectedFixed in
Red Hatredhat/libsouppkg:rpm/redhat/libsoupOther threatsAffected
  • >=9 <9.6
  • >=9.6 <9.8
Fixed in
  • 9.6
  • 9.8

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

A security update addressing all identified vulnerabilities in libsoup has been released by Red Hat for Red Hat Enterprise Linux 9. Users should apply the official update as described in Red Hat advisory RHSA-2025:7436 to mitigate these issues. No additional mitigations are specified or required beyond applying the update.

Description

Multiple security vulnerabilities have been identified in the libsoup HTTP client and server library for GNOME, affecting Red Hat Enterprise Linux 9. These vulnerabilities include integer overflow, heap buffer overflows, out-of-bounds reads, denial of service, double free, null pointer dereference, information disclosure, and memory leak issues. Red Hat has released a security update addressing these issues, rated as Important. Users of affected Red Hat Enterprise Linux 9 variants should apply the update to mitigate these vulnerabilities.

References

Community reviews

Loading reviews…