Skip to main content
CVE-2024-52531VulnerabilityPublished Updated

SUSE · security update for libsoup

Affects SUSESource GCVE Database

0
Authoritative record:CVE-2024-52531· Medium 6.5

Not known to be exploited · CVSS 6.5 Medium : upgrade the Red Hat redhat/libsoup package to 8.8.2 when convenient.

Data as of 26 Oct 2026, 09:15 UTC

CVSS 3.1 base score
6.5Medium
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.6% chance of exploitation in 30 days – higher than 52% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 8.8.2
CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:C/C:L/I:L/A:L

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 11 Nov 2024

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponised: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.

What to do

Upgrade the Red Hat redhat/libsoup package to 8.8.2.

Affected software

ProductAffectedFixed in
Red Hatredhat/libsouppkg:rpm/redhat/libsoupOther threatsAffected
  • =8.8
  • <8.8.2
Fixed in
  • 8.8.2

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

Red Hat has released updated libsoup packages for Red Hat Enterprise Linux 8.8 Extended Update Support to fix this vulnerability. Users should apply the security update as described in the Red Hat advisory RHSA-2025:1075 and the referenced article https://access.redhat.com/articles/11258. No additional mitigation steps are indicated by the vendor.

Description

The libsoup packages provide an HTTP client and server library for GNOME. Security Fix(es): * libsoup: buffer overflow via UTF-8 conversion in soup_header_parse_param_list_strict (CVE-2024-52531) For more details about the security issue(s), including the impact, a CVSS score, acknowledgments, and other related information, refer to the CVE page(s) listed in the References section.

References

Community reviews

Loading reviews…