Skip to main content
CVE-2024-52531VulnerabilityPublished Updated

Red Hat Security Advisory: libsoup security update

Affects Red Hat libsoupSource GCVE Database

0
Compare
Authoritative record:CVE-2024-52531· Medium 6.5

Not known to be exploited · CVSS 6.5 Medium : upgrade the Debian debian/libsoup package to 3.6.1 when convenient.

Data as of 5 Nov 2026, 13:05 UTC

CVSS 3.1 base score
6.5Medium
How severe the flaw is on the 0–10 CVSS scale.

Sources agree

CVSS scores by source
CNA (mitre)CVSS 3.16.5
CISA-ADPCVSS 3.18.4
Patch
Available – fixed in 3.6.1
CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:C/C:L/I:L/A:L

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 11 Nov 2024

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 5 Nov 2026.

What to do

Upgrade the Debian debian/libsoup package to 3.6.1.

Affected software

ProductAffectedFixed in
Debiandebian/libsouppkg:deb/debian/libsoupOther threatsAffected
  • <3.6.1
Fixed in
  • 3.6.1

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

Red Hat has released updated libsoup packages for Red Hat Enterprise Linux 8.4 variants that fix this vulnerability. Users should apply the security update as detailed in Red Hat's advisory and article (https://access.redhat.com/articles/11258) to remediate the issue. No additional mitigation steps are indicated beyond applying the official patch.

Description

A buffer overflow vulnerability exists in the libsoup HTTP client and server library for GNOME, specifically in the UTF-8 conversion function soup_header_parse_param_list_strict. This vulnerability is identified as CVE-2024-52531 and affects Red Hat Enterprise Linux 8.4 variants. Red Hat has issued a security advisory with an important severity rating and released updated packages to address this issue.

References

Community reviews

Loading reviews…