Skip to main content
CVE-2025-5987VulnerabilityPublished Updated

Red Hat Security Advisory: libssh security update

Affects Red Hat libsshSource GCVE Database

0
Compare
Authoritative record:CVE-2025-5987· High 8.1

Not known to be exploited · CVSS 8.1 High : upgrade Red Hat libssh to 0.11.2 soon.

Data as of 5 Nov 2026, 20:36 UTC

CVSS 3.1 base score
8.1High
How severe the flaw is on the 0–10 CVSS scale.

Thin evidence

One scorer or none
CVSS scores by source
CNA (redhat)CVSS 3.18.1
Patch
Available – fixed in 0.11.2
CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:H

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 7 Jul 2025

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 5 Nov 2026.

What to do

Upgrade libssh to 0.11.2.

Affected software

ProductAffectedFixed in
libsshAffected
  • >=0.10.0 <0.11.2
Fixed in
  • 0.11.2

AI-suggested

Red Hat has released an official security update for libssh in Red Hat Enterprise Linux 9.2 and related variants. Users should apply the update libssh-0.10.4-9.el9_2.2 and corresponding packages as provided in the Red Hat advisory RHSA-2026:0430. Detailed update instructions are available at https://access.redhat.com/articles/11258. No additional mitigation steps are indicated or required beyond applying the official patch.

Description

A security update for libssh addresses a vulnerability identified as CVE-2025-5987, involving an invalid return code for the chacha20 poly1305 cipher when using the OpenSSL backend. This issue affects Red Hat Enterprise Linux 9.2 and related variants. The vulnerability has been rated with moderate severity by Red Hat Product Security. The update fixes the issue in libssh version 0.10.4-9.el9_2.2. No public exploit or in-the-wild exploitation is currently known.

References

Community reviews

Loading reviews…