Skip to main content
CVE-2024-4418VulnerabilityPublished Updated

SUSE · security update for libvirt

Affects SUSESource GCVE Database

0
Authoritative record:CVE-2024-4418· Medium 6.2

Not known to be exploited · CVSS 6.2 Medium · fixed in SUSE package updates : update the Red Hat redhat/libvirt package when convenient.

Data as of 26 Oct 2026, 09:15 UTC

CVSS 3.1 base score
6.2Medium
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.4% chance of exploitation in 30 days – higher than 41% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 9.9, 9.7, 9.5
CVSS:3.1/AV:L/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 8 May 2024

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponised: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.

What to do

Upgrade the Red Hat redhat/libvirt package to 9.9, 9.7 or 9.5.

Affected software

ProductAffectedFixed in
Red Hatredhat/libvirtpkg:rpm/redhat/libvirtOther threatsAffected
  • >=9.4 <9.5
  • >=9.6 <9.7
  • >=9.8 <9.9
Fixed in
  • 9.5
  • 9.7
  • 9.9

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

A security update is available from Red Hat for libvirt packages on Red Hat Enterprise Linux 9. Users should apply the official patches as described in the Red Hat advisory RHSA-2024:4757. Refer to https://access.redhat.com/articles/11258 for update instructions. No additional mitigation steps are indicated by the vendor.

Description

A security update addresses a stack use-after-free vulnerability in the libvirt component of Kernel-based Virtual Machine (KVM) virtualization on Linux. The flaw, identified as CVE-2024-4418, occurs in the virNetClientIOEventLoop() function and could potentially lead to memory corruption. This vulnerability affects Red Hat Enterprise Linux 9 and related packages. A patch is available from Red Hat to remediate the issue.

References

Community reviews

Loading reviews…