Skip to main content
CVE-2025-6170VulnerabilityPublished Updated

Red Hat Security Advisory: libxml2 security update

Affects Red Hat libxml2Source GCVE Database

0
Compare
Authoritative record:CVE-2025-6170· Low 2.5

Not known to be exploited · CVSS 2.5 Low · fixed in Red Hat Enterprise Linux 10 package updates : update Red Hat libxml2 when convenient.

Data as of 30 Oct 2026, 00:19 UTC

CVSS 3.1 base score
2.5Low
How severe the flaw is on the 0–10 CVSS scale.

Thin evidence

One scorer or none
CVSS scores by source
CNA (redhat)CVSS 3.12.5
Patch
Available – fixed in 2.14.5, 10.2, 8.10.6
CVSS:3.1/AV:L/AC:H/PR:N/UI:R/S:U/C:N/I:N/A:L

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 16 Jun 2025

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 29 Oct 2026.

What to do

Upgrade libxml2 to 2.14.5; gnome/libxml2 to 10.2 or 8.10.6.

Affected software

ProductAffectedFixed in
libxml2Affected
  • <2.14.5
Fixed in
  • 2.14.5
GitHubgnome/libxml2pkg:github/gnome/libxml2Other threatsAffected
  • =0
  • >=8.0.0 <8.10.6
  • >=10.0.0 <10.2
Fixed in
  • 8.10.6
  • 10.2

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

Red Hat has released updated libxml2 packages for Red Hat Enterprise Linux 8.6 Extended Life Cycle and AUS variants that fix this vulnerability. Users should apply the official Red Hat security update as described in the advisory (RHSA-2026:79120) to remediate this issue.

Description

A security update for the libxml2 library addresses a stack buffer overflow vulnerability (CVE-2025-6170) in the xmllint interactive shell command handling. This vulnerability has been rated with a low security impact by Red Hat. The update is available for Red Hat Enterprise Linux 8.6 variants. No public exploit or active exploitation is reported at this time.

References

Community reviews

Loading reviews…