Skip to main content
CVE-2025-6170VulnerabilityPublished Updated

Red Hat Security Advisory: libxml2 security update

Affects Red Hat libxml2Source GCVE Database

0
Compare
Authoritative record:CVE-2025-6170· Low 2.5

Not known to be exploited · CVSS 2.5 Low · fixed in Red Hat Enterprise Linux 10 package updates : update Red Hat libxml2 when convenient.

Data as of 30 Oct 2026, 01:02 UTC

CVSS 3.1 base score
2.5Low
How severe the flaw is on the 0–10 CVSS scale.

Thin evidence

One scorer or none
CVSS scores by source
CNA (redhat)CVSS 3.12.5
Patch
Available – fixed in 2.14.5, 10.2, 8.10.6
CVSS:3.1/AV:L/AC:H/PR:N/UI:R/S:U/C:N/I:N/A:L

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 16 Jun 2025

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 29 Oct 2026.

What to do

Upgrade libxml2 to 2.14.5; gnome/libxml2 to 10.2 or 8.10.6.

Affected software

ProductAffectedFixed in
libxml2Affected
  • <2.14.5
Fixed in
  • 2.14.5
GitHubgnome/libxml2pkg:github/gnome/libxml2Other threatsAffected
  • =0
  • >=8.0.0 <8.10.6
  • >=10.0.0 <10.2
Fixed in
  • 8.10.6
  • 10.2

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

Red Hat has released updated libxml2 packages for Red Hat Enterprise Linux 9 and its variants to address this vulnerability. Users should apply the security update as described in the Red Hat advisory (RHSA-2026:39317) to remediate the issue. Detailed update instructions are available at https://access.redhat.com/articles/11258. No additional mitigation steps are indicated.

Description

A stack buffer overflow vulnerability (CVE-2025-6170) was discovered in the xmllint interactive shell command handling of the libxml2 library. This vulnerability affects Red Hat Enterprise Linux 9 and related variants. Red Hat has released a security update to address this issue, which is rated with a low security impact. The vulnerability is related to improper handling of input in the interactive shell, potentially leading to a stack buffer overflow.

References

Community reviews

Loading reviews…