Skip to main content
CVE-2026-88807VulnerabilityPublished

Red Hat Security Advisory: libXrender security update

Affects Red Hat libXrenderSource GCVE Database

0
Compare
Authoritative record:CVE-2026-88807· High 8.9

Not known to be exploited · CVSS 8.9 High : upgrade the Debian debian/libxrender package to 0.9.13 soon.

Data as of 30 Oct 2026, 02:31 UTC

CVSS 4.0 base score
8.9High
How severe the flaw is on the 0–10 CVSS scale.
Patch
Available – fixed in 0.9.13
CVSS:4.0/AV:N/AC:H/AT:N/PR:N/UI:A/VC:H/VI:H/VA:H/SC:H/SI:H/SA:H

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 21 Sep 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 29 Oct 2026.

What to do

Upgrade libXrender and the Debian debian/libxrender package to 0.9.13.

Affected software

ProductAffectedFixed in
X.orglibXrenderAffected
  • <0.9.13
Fixed in
  • 0.9.13
Debiandebian/libxrenderpkg:deb/debian/libxrenderOther threatsAffected
  • <0.9.13
Fixed in
  • 0.9.13

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

Red Hat has released updated libXrender packages as part of RHSA-2026:91057 to fix this vulnerability. Users should apply the official Red Hat security update for libXrender on Red Hat Enterprise Linux 9 as soon as possible. Detailed update instructions are available at https://access.redhat.com/articles/11258. No additional mitigation steps are indicated by the vendor advisory.

Description

A heap overflow vulnerability in the X.Org X11 libXrender runtime library's RenderQueryPictFormats function allows for code injection. This security flaw is tracked as CVE-2026-88807 and affects Red Hat Enterprise Linux 9 across multiple architectures. Red Hat has issued an important security update to address this issue.

References

Community reviews

Loading reviews…