Skip to main content
CVE-2026-56434VulnerabilityPublished Updated

Red Hat Security Advisory: nginx security update

Affects Red Hat nginxSource GCVE Database

0
Compare

Mentioned vulnerabilities

Authoritative record:CVE-2026-56434· Medium 6.5

Not known to be exploited · CVSS 6.5 Medium · fixed in Red Hat package updates : update Red Hat nginx when convenient.

Data as of 2 Nov 2026, 04:31 UTC

CVSS 3.1 base score
6.5Medium
How severe the flaw is on the 0–10 CVSS scale.
Patch
Available – fixed in 37.0.3.1, 1.31.3, 1.30.4
CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:N/I:L/A:H

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 15 Jul 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 1 Nov 2026.

What to do

Upgrade NGINX to 37.0.3.1 (Plus); 1.31.3 or 1.30.4 (Open Source).

Affected software

ProductAffectedFixed in
F5NGINX PlusAffected
  • >=37.0.0.1 <37.0.3.1
  • >=R33
  • =R36
Fixed in
  • 37.0.3.1
F5NGINX Open SourceAffected
  • >=1.31.2 <1.31.3
Fixed in
  • 1.31.3
F5NGINX Open SourceAffected
  • >=0.8.11 <1.30.4
Fixed in
  • 1.30.4

AI-suggested

Red Hat has released updated nginx packages for Red Hat Enterprise Linux 10 and related products that address these vulnerabilities. Users should apply these official updates as described in the Red Hat advisory (https://access.redhat.com/articles/11258) to remediate the issues. Since the advisory provides an official fix, applying the update is the recommended mitigation.

Description

Red Hat has issued a security advisory for nginx addressing two vulnerabilities: a heap buffer over-read that can lead to memory modification or denial of service (CVE-2026-56434), and a memory disclosure and denial of service issue in the ngx_http_slice_module (CVE-2026-60005). These vulnerabilities affect Red Hat Enterprise Linux 10 and related products. The update is rated as Important by Red Hat Product Security. Users should apply the provided security update to mitigate these issues.

References

Community reviews

Loading reviews…