Skip to main content
CVE-2026-42945VulnerabilityPublished Updated

Red Hat Security Advisory: nginx:1.26 security update

Affects Red Hat nginx:1.26Source GCVE Database

0
Compare
Authoritative record:CVE-2026-42945· High 8.1

Not known to be exploited · CVSS 8.1 High : upgrade Red Hat nginx:1.26 to 1.30.1 soon.

Data as of 3 Nov 2026, 19:31 UTC

CVSS 3.1 base score
8.1High
How severe the flaw is on the 0–10 CVSS scale.
Patch
Available – fixed in 1.30.1
CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:H

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 13 May 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 3 Nov 2026.

What to do

Upgrade NGINX Open Source to 1.30.1.

Affected software

ProductAffectedFixed in
F5NGINX PlusAffected
  • =R36
  • =R32
Fixed in–
F5NGINX Open SourceAffected
  • >=0.6.27 <1.30.1
Fixed in
  • 1.30.1

Description

nginx is a web and proxy server supporting HTTP and other protocols, with a focus on high concurrency, performance, and low memory usage. Security Fix(es): * nginx: NGINX: Arbitrary Code Execution Vulnerability (CVE-2026-42945) For more details about the security issue(s), including the impact, a CVSS score, acknowledgments, and other related information, refer to the CVE page(s) listed in the References section.

References

Community reviews

Loading reviews…