Skip to main content
CVE-2024-22020VulnerabilityPublished Updated

Red Hat Security Advisory: nodejs:18 security update

Affects Red HatSource GCVE Database

0

Mentioned vulnerabilities

Not known to be exploited : upgrade to 18.20.5 when convenient.

Data as of 25 Oct 2026, 19:02 UTC

Severity
Medium

Rated by Threat Radar · No CVSS score from NVD or the CNA

EPSS
1.1% chance of exploitation in 30 days – higher than 65% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 18.20.5

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 3 Sep 2024

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponised: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 2026-10-25.

What to do

Upgrade Red Hat to 18.20.5.

Affected software

ProductAffectedFixed in
Red Hat Product Security Red HatAffected
  • >=18.20.4 <18.20.5
  • Red Hat
  • Red Hat Enterprise Linux
  • Red Hat Enterprise Linux AppStream (v. 9)
  • src
  • nodejs-1:18.20.4-1.module+el9.4.0+22195+c221878e.src::nodejs:18
Fixed in
  • 18.20.5

AI-suggested

Red Hat has released an official security update for Node.js 18 on Red Hat Enterprise Linux 9 and related variants that addresses these vulnerabilities. Users should apply the update as described in Red Hat advisory RHSA-2024:6147 and the linked article https://access.redhat.com/articles/11258. No additional mitigation steps are indicated beyond applying the official patch.

Description

A security update for Node.js addresses two vulnerabilities: a denial of service in node-tar due to lack of folder depth validation (CVE-2024-28863) and a bypass of network import restrictions via data URL in Node.js (CVE-2024-22020). The update is rated as moderate severity by Red Hat Product Security and affects Node.js 18 on Red Hat Enterprise Linux 9 and related distributions. The update mitigates these issues by applying patches provided by Red Hat.

References

Community reviews

Loading reviews…