Skip to main content
CVE-2025-22150VulnerabilityPublished Updated

Red Hat Security Advisory: nodejs:18 security update

Affects Red HatSource GCVE Database

0

Mentioned vulnerabilities

Not known to be exploited : upgrade to 18.20.6 when convenient.

Data as of 25 Oct 2026, 19:02 UTC

Severity
Medium

Rated by Threat Radar · No CVSS score from NVD or the CNA

EPSS
0.7% chance of exploitation in 30 days – higher than 55% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 18.20.6

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 17 Feb 2025

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponised: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 2026-10-25.

What to do

Upgrade Red Hat to 18.20.6.

Affected software

ProductAffectedFixed in
Red Hat Product Security Red HatAffected
  • >=18.0.0 <18.20.6
  • Red Hat
  • Red Hat Enterprise Linux
  • Red Hat Enterprise Linux AppStream (v. 8)
  • src
  • nodejs-1:18.20.6-1.module+el8.10.0+22776+24cd6c55.src::nodejs:18
Fixed in
  • 18.20.6

AI-suggested

Red Hat has released updated Node.js 18 packages (version 18.20.6) that fix these vulnerabilities. Users should apply the official Red Hat update as described in the advisory (RHSA-2025:1582) and the linked article https://access.redhat.com/articles/11258. No additional mitigations are indicated or required beyond applying this update.

Description

This advisory addresses two security vulnerabilities in Node.js 18 as packaged by Red Hat for Red Hat Enterprise Linux 8. The first vulnerability (CVE-2025-22150) involves the undici HTTP client library using insufficiently random values, which can affect cryptographic strength. The second vulnerability (CVE-2025-23085) involves a memory leak caused by GOAWAY HTTP/2 frames occurring outside the heap. Red Hat has released an update to Node.js 18 to fix these issues. The update is rated as having a moderate security impact. No CVSS scores are provided in the advisory.

References

Community reviews

Loading reviews…