Skip to main content
CVE-2024-42934VulnerabilityPublished Updated

SUSE · security update for OpenIPMI

Affects SUSESource GCVE Database

0
Authoritative record:CVE-2024-42934· Medium 5.0

Not known to be exploited · CVSS 5.0 Medium : upgrade the Debian openipmi package to 2.0.36 when convenient.

Data as of 26 Oct 2026, 09:15 UTC

CVSS 3.1 base score
5.0Medium
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.3% chance of exploitation in 30 days – higher than 33% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 2.0.36
CVSS:3.1/AV:A/AC:H/PR:N/UI:N/S:U/C:L/I:L/A:L

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 9 Oct 2024

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponised: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.

What to do

Upgrade the Debian openipmi package to 2.0.36.

Affected software

ProductAffectedFixed in
Debianopenipmipkg:deb/openipmiOther threatsAffected
  • <2.0.36
Fixed in
  • 2.0.36

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

Red Hat has released an official security update for OpenIPMI to address this vulnerability. Users of Red Hat Enterprise Linux 9.2 Extended Update Support should apply the update as described in the Red Hat advisory RHSA-2024:8081. For detailed update instructions, refer to https://access.redhat.com/articles/11258. Applying this update mitigates the vulnerability.

Description

A security vulnerability (CVE-2024-42934) was identified in the OpenIPMI package used in Red Hat Enterprise Linux 9.2 Extended Update Support. The vulnerability involves a missing check on the authorization type for incoming LAN messages in the IPMI simulator component. This flaw could allow unauthorized access or actions via IPMI LAN messages. Red Hat has released an update to address this issue, rated with moderate security impact.

References

Community reviews

Loading reviews…