Skip to main content
CVE-2025-12817VulnerabilityPublished Updated

SUSE · security update for postgresql

Affects SUSESource GCVE Database

0

Mentioned vulnerabilities

Authoritative record:CVE-2025-12817· Low 3.1

Not known to be exploited · CVSS 3.1 Low : upgrade the Red Hat redhat/postgresql package to 9.6.23 when convenient.

Data as of 26 Oct 2026, 09:15 UTC

CVSS 3.1 base score
3.1Low
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.2% chance of exploitation in 30 days – higher than 15% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 9.6.23
CVSS:3.1/AV:N/AC:H/PR:L/UI:N/S:U/C:N/I:N/A:L

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 13 Nov 2025

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponised: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.

What to do

Upgrade the Red Hat redhat/postgresql package to 9.6.23.

Affected software

ProductAffectedFixed in
Red Hatredhat/postgresqlpkg:rpm/redhat/postgresqlOther threatsAffected
  • <9.6.23 >=9.6
Fixed in
  • 9.6.23

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

A security update for PostgreSQL 15 is available for Red Hat Enterprise Linux 9.4 Extended Update Support. Users should apply this update promptly to remediate the vulnerabilities. Detailed instructions for applying the update are available from Red Hat's advisory and knowledge base articles. No additional mitigation actions are indicated by the vendor.

Description

Two security vulnerabilities have been identified in PostgreSQL affecting Red Hat Enterprise Linux 9.4 Extended Update Support. The first vulnerability (CVE-2025-12817) involves the CREATE STATISTICS command not properly checking for schema CREATE privileges. The second vulnerability (CVE-2025-12818) involves libpq undersizing memory allocations due to integer wraparound. Both issues have been addressed in a security update released by Red Hat. The update is rated as having a moderate security impact. Users of affected Red Hat Enterprise Linux 9.4 versions should apply the provided security update to remediate these issues.

References

Community reviews

Loading reviews…