CVE-2025-12817: PostgreSQL · Missing Authorization
Affects PostgreSQLSource CVE Database V5
Not known to be exploited · CVSS 3.1 Low · fixed in 18.1 : update PostgreSQL when convenient.
Data as of 26 Oct 2026, 06:26 UTC
- EPSS
- 0.2% chance of exploitation in 30 days – higher than 15% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- Patch
- Available – fixed in 18.1, 17.7, 16.11 +3
CVSS:3.1/AV:N/AC:H/PR:L/UI:N/S:U/C:N/I:N/A:LExploitation evidence
Disclosed: evidence found.
CVE published 13 Nov 2025
Detectable: no evidence on record.
No public nuclei template indexed
Weaponised: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 2026-10-26.
What to do
Upgrade to a fixed release listed under Affected software.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
Postgresqlpostgresql/postgresqlpkg:deb/postgresql/postgresqlOther threats | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
European organizations should promptly upgrade affected PostgreSQL instances to versions 18.1, 17.7, 16.11, 15.15, 14.20, or 13.23 or later where the vulnerability is fixed. Until patching, restrict CREATE STATISTICS privileges to trusted users only and monitor usage patterns for unusual statistics creation attempts. Implement role-based access controls to limit table ownership and schema modification rights. Regularly audit database permissions and schema objects to detect unauthorized statistics objects. Employ database activity monitoring tools to alert on failed CREATE STATISTICS commands that may indicate attempted exploitation. Additionally, educate database administrators and users about the risk and encourage prompt reporting of anomalies. Avoid granting unnecessary CREATE privileges in shared environments to reduce attack surface.
Description
CVE-2025-12817 is a low-severity vulnerability in PostgreSQL affecting versions prior to 18.1, 17.7, 16.11, 15.15, 14.20, and 13.23. It involves missing authorization checks in the CREATE STATISTICS command, allowing a table owner to cause denial of service (DoS) against other users by creating statistics objects in any schema. This prevents other users with CREATE privileges from creating statistics with the same name, leading to failed operations. Exploitation requires low privileges (table owner) but no user interaction.