SUSE · security update for openjpeg2
Affects SUSESource GCVE Database
Mentioned vulnerabilities
Not known to be exploited : upgrade the Red Hat redhat/openjpeg2 package to 9.8.0 when convenient.
Data as of 26 Oct 2026, 08:30 UTC
Rated by Threat Radar · No CVSS score from NVD or the CNA
- EPSS
- 0.3% chance of exploitation in 30 days – higher than 24% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- Patch
- Available – fixed in 9.8.0
Exploitation evidence
Disclosed: evidence found.
CVE published 13 May 2025
Detectable: no evidence on record.
No public nuclei template indexed
Weaponised: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.
What to do
Upgrade the Red Hat redhat/openjpeg2 package to 9.8.0.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
Red Hatredhat/openjpeg2pkg:rpm/redhat/openjpeg2Other threats | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
A security update addressing these vulnerabilities is available from Red Hat and should be applied to all affected systems running Red Hat Enterprise Linux 9 versions prior to 9.8.0. Refer to the official Red Hat advisory RHSA-2025:7309 and the linked update instructions for applying the patch. Applying this update mitigates the risk posed by these vulnerabilities.
Description
Two heap buffer overflow vulnerabilities (CVE-2024-56826 and CVE-2024-56827) were discovered in the OpenJPEG open source library used for JPEG2000 image processing. These vulnerabilities affect Red Hat Enterprise Linux 9 versions prior to 9.8.0. Red Hat has released a security update to address these issues, which have been rated with moderate severity. The update should be applied to affected systems to mitigate the risk.
References
- access.redhat.com/errata/RHSA-2025:7309 (opens in a new tab)
- docs.redhat.com/en/documentation/red_hat_enterprise_linux/9/html/9.6_release_notes/index (opens in a new tab)
- access.redhat.com/security/updates/classification/ (opens in a new tab)
- bugzilla.redhat.com/show_bug.cgi?id=2335172 (opens in a new tab)
- bugzilla.redhat.com/show_bug.cgi?id=2335174 (opens in a new tab)
- security.access.redhat.com/data/csaf/v2/advisories/2025/rhsa-2025_7309.json (opens in a new tab)
- suse.com/support/security/rating/ (opens in a new tab)
- ftp.suse.com/pub/projects/security/csaf/rhsa-2025_7309.json (opens in a new tab)
- lists.suse.com/pipermail/suse-liberty-linux-updates/2025-May/001335.html (opens in a new tab)
- suse.com/security/cve/CVE-2024-56826/ (opens in a new tab)
- suse.com/security/cve/CVE-2024-56827/ (opens in a new tab)