SUSE · Recommended update for helm
Affects SUSESource GCVE Database
Not known to be exploited : upgrade to 4.15.3 when convenient.
Data as of 25 Oct 2026, 19:02 UTC
Rated by Threat Radar · No CVSS score from NVD or the CNA
- EPSS
- 0.5% chance of exploitation in 30 days – higher than 47% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- Patch
- Available – fixed in 4.15.3
Exploitation evidence
Disclosed: evidence found.
CVE published 5 Dec 2024
Detectable: no evidence on record.
No public nuclei template indexed
Weaponised: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 2026-10-25.
What to do
Upgrade SUSE to 4.15.3.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| SUSE Product Security Team SUSE | Affected
| Fixed in
|
AI-suggested
A fix is available. Users should upgrade Helm to version 3.14.1 or later. For Red Hat OpenShift Container Platform 4.15 users, upgrade to version 4.15.3 or later, which includes updated container images addressing this vulnerability. Follow vendor-provided upgrade instructions for OpenShift clusters using the OpenShift CLI or web console. No additional mitigation steps are indicated by the vendor advisory.
Description
A path traversal vulnerability (CVE-2024-25620) was discovered in Helm's dependency management component. This vulnerability could allow improper handling of file paths, potentially leading to unauthorized file access or manipulation during dependency management operations. The issue has been addressed in Helm versions 3.14.1 and later, as well as in Red Hat OpenShift Container Platform 4.15.3 images. Users of affected versions are advised to upgrade to these fixed releases to mitigate the risk.
References
- access.redhat.com/errata/RHSA-2024:1255 (opens in a new tab)
- access.redhat.com/security/updates/classification/ (opens in a new tab)
- bugzilla.redhat.com/show_bug.cgi?id=2264336 (opens in a new tab)
- issues.redhat.com/browse/OCPBUGS-24086 (opens in a new tab)
- issues.redhat.com/browse/OCPBUGS-25831 (opens in a new tab)
- issues.redhat.com/browse/OCPBUGS-29080 (opens in a new tab)
- issues.redhat.com/browse/OCPBUGS-29661 (opens in a new tab)
- issues.redhat.com/browse/OCPBUGS-30189 (opens in a new tab)
- issues.redhat.com/browse/OCPBUGS-30412 (opens in a new tab)
- security.access.redhat.com/data/csaf/v2/advisories/2024/rhsa-2024_1255.json (opens in a new tab)
- suse.com/support/security/rating/ (opens in a new tab)
- ftp.suse.com/pub/projects/security/csaf/suse-ru-2024_4213-1.json (opens in a new tab)
- lists.suse.com/pipermail/sle-updates/2024-December/037756.html (opens in a new tab)
- bugzilla.suse.com/1219969 (opens in a new tab)
- bugzilla.suse.com/1220207 (opens in a new tab)
- suse.com/security/cve/CVE-2024-25620/ (opens in a new tab)
- suse.com/security/cve/CVE-2024-26147/ (opens in a new tab)