Skip to main content
CVE-2026-49978VulnerabilityPublished Updated

Red Hat Security Advisory: OpenShift Virtualization v4.17 Images

Affects Red HatSource GCVE Database

0
Compare
Authoritative record:CVE-2026-49978· Medium 6.3

Not known to be exploited · CVSS 6.3 Medium · fixed in Red Hat package updates : update Red Hat dompurify when convenient.

Data as of 30 Oct 2026, 22:42 UTC

CVSS 4.0 base score
6.3Medium
How severe the flaw is on the 0–10 CVSS scale.
Patch
Available – fixed in 3.4.6, 3.4.7
CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:A/VC:N/VI:N/VA:N/SC:H/SI:H/SA:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 14 Jul 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 30 Oct 2026.

What to do

Upgrade DOMPurify to 3.4.6; dompurify to 3.4.7.

Affected software

ProductAffectedFixed in
cure53DOMPurifyAffected
  • <3.4.6
Fixed in
  • 3.4.6
npmdompurifypkg:npm/dompurifyOther threatsAffected
  • <3.4.7
Fixed in
  • 3.4.7

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

Red Hat recommends applying the OpenShift Virtualization v4.17 image updates that include fixes and enhancements. Before applying this update, ensure all previously released errata relevant to your system have been applied. Follow Red Hat's official update procedures as detailed in their documentation. No additional mitigation steps are specified.

Description

This advisory concerns OpenShift Virtualization v4.17 images from Red Hat, which address several bugs and enhancements. It references CVE-2026-49978, categorized under CWE-79 (Cross-site Scripting). The update is available as part of the v4.17 release images.

References

Community reviews

Loading reviews…