Skip to main content
CVE-2025-6020VulnerabilityPublished Updated

Red Hat Security Advisory: pam security update

Affects Red Hat pamSource GCVE Database

0

Mentioned vulnerabilities

Authoritative record:CVE-2025-6020· High 7.8

Not known to be exploited · CVSS 7.8 High : upgrade Red Hat linux-pam to 1.7.1 soon.

Data as of 26 Oct 2026, 10:12 UTC

CVSS 3.1 base score
7.8High
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.4% chance of exploitation in 30 days – higher than 40% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 1.7.1
CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 17 Jun 2025

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponised: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.

What to do

Upgrade linux-pam to 1.7.1.

Affected software

ProductAffectedFixed in
linux-pamAffected
  • <1.7.1
Fixed in
  • 1.7.1
GitHublinux-pampkg:github/linux-pamOther threatsAffected
  • <1.7.1
Fixed in
  • 1.7.1

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

Red Hat has released updated PAM packages to address this vulnerability. Users of Red Hat Enterprise Linux 8 should apply the security update pam-1.3.1-38.el8_10 or later as provided in the Red Hat advisory RHSA-2025:14557. Detailed update instructions are available at https://access.redhat.com/articles/11258. Applying this official fix mitigates the vulnerability. No additional mitigation steps are indicated by the vendor.

Description

Pluggable Authentication Modules (PAM) provide a system to set up authentication policies without the need to recompile programs to handle authentication. Security Fix(es): * linux-pam: Linux-pam directory Traversal (CVE-2025-6020) For more details about the security issue(s), including the impact, a CVSS score, acknowledgments, and other related information, refer to the CVE page(s) listed in the References section.

References

Community reviews

Loading reviews…