Skip to main content
CVE-2025-8941VulnerabilityPublished Updated

Red Hat Security Advisory: pam security update

Affects Red Hat pamSource GCVE Database

0

Mentioned vulnerabilities

Authoritative record:CVE-2025-8941· High 7.8

Not known to be exploited · CVSS 7.8 High · fixed in Red Hat package updates : patch Red Hat pam soon.

Data as of 26 Oct 2026, 10:12 UTC

CVSS 3.1 base score
7.8High
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.2% chance of exploitation in 30 days – higher than 19% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 9.3, 9.1, 8.3
CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 13 Aug 2025

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponised: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.

What to do

Upgrade Red Hat pam to 9.3, 9.1 or 8.3.

Affected software

ProductAffectedFixed in
Red Hat Product Security Red HatAffected
  • >=8.2 <8.3
  • >=9.0 <9.1
  • >=9.2 <9.3
  • Red Hat
  • Red Hat Enterprise Linux
  • Red Hat Enterprise Linux AppStream E4S (v.9.0)
  • Red Hat Enterprise Linux BaseOS E4S (v.9.0)
  • src
  • Red Hat Enterprise Linux BaseOS AUS (v.8.6)
  • Red Hat Enterprise Linux BaseOS E4S (v.8.6)
  • Red Hat Enterprise Linux BaseOS TUS (v.8.6)
  • Red Hat Enterprise Linux BaseOS AUS (v. 8.2)
  • pam-0:1.3.1-8.el8_2.2.src
Fixed in
  • 8.3
  • 9.1
  • 9.3

AI-suggested

Red Hat has released official security updates for affected versions of Red Hat Enterprise Linux. Users should apply the updated linux-pam packages as described in Red Hat advisories RHSA-2025:15100 and RHSA-2025:15101. Detailed update instructions are available at https://access.redhat.com/articles/11258. Applying these updates will remediate the vulnerability. No additional mitigation actions are indicated by the vendor.

Description

Pluggable Authentication Modules (PAM) provide a system to set up authentication policies without the need to recompile programs to handle authentication. Security Fix(es): * linux-pam: Incomplete fix for CVE-2025-6020 (CVE-2025-8941) For more details about the security issue(s), including the impact, a CVSS score, acknowledgments, and other related information, refer to the CVE page(s) listed in the References section.

References

Community reviews

Loading reviews…