Skip to main content
CVE-2024-25126VulnerabilityPublished Updated

SUSE · security update for pcs

Affects SUSESource GCVE Database

0

Mentioned vulnerabilities

Not known to be exploited · 35% EPSS : upgrade the Red Hat redhat/pcs package to 9.4 when convenient.

Data as of 26 Oct 2026, 09:15 UTC

Severity
Medium

Rated by Threat Radar · No CVSS score from NVD or the CNA

EPSS
35.3% chance of exploitation in 30 days – higher than 98% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 9.4

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 30 Apr 2024

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponised: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.

What to do

Upgrade the Red Hat redhat/pcs package to 9.4.

Affected software

ProductAffectedFixed in
Red Hatredhat/pcspkg:rpm/redhat/pcsOther threatsAffected
  • =9.0
  • <9.4
  • >=9.4
  • <=9.8
Fixed in
  • 9.4

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

A security update is available from Red Hat and should be applied to affected systems. The update addresses the identified denial of service vulnerabilities in rubygem-rack. Administrators should follow the guidance in the Red Hat advisory RHSA-2024:2113 and apply the update as soon as possible to mitigate the risk. No additional mitigation actions are specified by the vendor.

Description

The pcs packages, which provide command-line configuration for Pacemaker and Corosync utilities in Red Hat Enterprise Linux 9, have received a security update addressing multiple denial of service (DoS) vulnerabilities in the rubygem-rack component. These vulnerabilities include issues in Content-Type parsing, Range header handling, and header parsing. The update is rated as having moderate security impact and is available for various Red Hat Enterprise Linux 9 High Availability and Resilient Storage variants across multiple architectures.

References

Community reviews

Loading reviews…