Skip to main content
CVE-2025-1217VulnerabilityPublished Updated

Red Hat Security Advisory: php security update

Affects Red HatSource GCVE Database

0

Not known to be exploited · fixed in 8.4.5 : update Red Hat when convenient.

Data as of 26 Oct 2026, 06:26 UTC

Severity
Medium

Rated by Threat Radar · No CVSS score from NVD or the CNA

EPSS
0.5% chance of exploitation in 30 days – higher than 47% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 8.4.5, 8.3.19, 8.2.28 +1

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 13 May 2025

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponised: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 2026-10-26.

What to do

Upgrade Red Hat to 8.4.5, 8.3.19, 8.2.28 or 8.1.32.

Affected software

ProductAffectedFixed in
Red Hat Product Security Red HatAffected
  • <8.1.32
  • >=8.2.0 <8.2.28
  • >=8.3.0 <8.3.19
  • >=8.4.0 <8.4.5
  • Red Hat
  • Red Hat Enterprise Linux
  • Red Hat Enterprise Linux AppStream (v. 9)
  • s390x
  • php-dba-debuginfo-0:8.0.30-3.el9_6.s390x
Fixed in
  • 8.1.32
  • 8.2.28
  • 8.3.19
  • 8.4.5

AI-suggested

An official patch is available and should be applied to affected PHP versions to remediate this vulnerability. Red Hat has released updated PHP packages for Red Hat Enterprise Linux 9 and related distributions. Users should follow vendor guidance to update PHP to versions 8.1.32 or later, 8.2.28 or later, 8.3.19 or later, or 8.4.5 or later as applicable. No additional mitigation steps are indicated by the vendor advisory.

Description

A moderate severity vulnerability exists in PHP's HTTP stream wrapper header parser affecting versions prior to 8.1.32, 8.2.28, 8.3.19, and 8.4.5. The parser incorrectly handles folded HTTP headers, which can cause misinterpretation of HTTP responses including incorrect headers and MIME types. This issue has been addressed by a security update available from Red Hat and other vendors.

References

Community reviews

Loading reviews…