Skip to main content
CVE-2024-8929VulnerabilityPublished Updated

Red Hat Security Advisory: php:7.4 security update

Affects Red Hat php:7.4Source GCVE Database

0
Authoritative record:CVE-2024-8929· Medium 5.8

Not known to be exploited · CVSS 5.8 Medium · fixed in Red Hat package updates : update Red Hat php-src when convenient.

Data as of 26 Oct 2026, 09:15 UTC

CVSS 3.1 base score
5.8Medium
How severe the flaw is on the 0–10 CVSS scale.
EPSS
2.2% chance of exploitation in 30 days – higher than 82% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 8.3.14, 8.2.26, 8.1.31
CVSS:3.1/AV:A/AC:H/PR:L/UI:N/S:C/C:H/I:N/A:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 22 Nov 2024

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponised: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.

What to do

Upgrade php/php-src to 8.3.14, 8.2.26 or 8.1.31.

Affected software

ProductAffectedFixed in
GitHubphp/php-srcpkg:github/php/php-srcOther threatsAffected
  • >=8.1.0 <8.1.31
  • >=8.2.0 <8.2.26
  • >=8.3.0 <8.3.14
Fixed in
  • 8.1.31
  • 8.2.26
  • 8.3.14

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

Official patches are available and have been released by Red Hat for affected PHP versions. Users should apply the updates provided in Red Hat Security Advisory RHSA-2026:2470 to remediate this vulnerability. No additional mitigation steps are required beyond applying the official fixes.

Description

A heap buffer over-read vulnerability (CVE-2024-8929) exists in the mysqlnd extension of PHP, allowing a hostile MySQL server to cause the PHP client to leak partial heap contents. This may disclose data from other SQL requests or other users on the same server. The vulnerability affects multiple PHP versions prior to fixed releases. Red Hat has released official patches addressing this issue in their php:7.4 module for Red Hat Enterprise Linux 8. The security impact is rated as moderate.

References

Community reviews

Loading reviews…