Skip to main content
CVE-2026-6722VulnerabilityPublished Updated

Red Hat Security Advisory: php:7.4 security update

Affects Red Hat php:7.4Source GCVE Database

0
Compare

Mentioned vulnerabilities

Authoritative record:CVE-2026-6722· Critical 9.5

Not known to be exploited · CVSS 9.5 Critical · fixed in Red Hat package updates : patch Red Hat php-src as a priority.

Data as of 6 Nov 2026, 01:32 UTC

CVSS 4.0 base score
9.5Critical
How severe the flaw is on the 0–10 CVSS scale.
Patch
Available – fixed in 8.5.6, 8.4.21, 8.3.31 +1
CVSS:4.0/AV:N/AC:H/AT:P/PR:N/UI:N/VC:H/VI:H/VA:H/SC:H/SI:H/SA:H/AU:Y/RE:M/U:Red

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 10 May 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 5 Nov 2026.

What to do

Upgrade php/php-src to 8.5.6, 8.4.21, 8.3.31 or 8.2.31.

Affected software

ProductAffectedFixed in
PHP GroupPHPAffected
  • ≥ 8.2.*, < 8.2.31
  • ≥ 8.3.*, < 8.3.31
  • ≥ 8.4.*, < 8.4.21
  • ≥ 8.5.*, < 8.5.6
Fixed in–
GitHubphp/php-srcpkg:github/php/php-srcOther threatsAffected
  • <8.2.31
  • <8.3.31
  • <8.4.21
  • <8.5.6
Fixed in
  • 8.2.31
  • 8.3.31
  • 8.4.21
  • 8.5.6

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

Red Hat has released an official security update for the PHP 7.4 module in Red Hat Enterprise Linux 8 that addresses all listed vulnerabilities. Users should apply this update promptly to remediate these security issues. Detailed instructions for applying the update are available in the Red Hat advisory at https://access.redhat.com/articles/11258. No additional mitigation steps are indicated beyond applying the official patch.

Description

Multiple security vulnerabilities have been identified and fixed in the PHP 7.4 module for Red Hat Enterprise Linux 8. These include a remote code execution via a use-after-free in the PHP SOAP extension, denial of service through improper handling of signed characters in ctype functions, cross-site scripting in PHP-FPM due to improper URL sanitation, memory corruption and information disclosure in PHP SoapServer, a NULL pointer dereference in the SOAP apache:Map decoder, and a signed integer overflow in the metaphone() function. Red Hat has issued an important security update addressing these issues.

References

Community reviews

Loading reviews…